Create a bootable ubuntu USB in mac OS X

Download the Linux distribution of your choice, my case is ubuntu server.

Usually the file will be save in you Downloads folder, well leave it there so you can just copy and paste my code.  To make it simpler I  just selected it and pressed enter to rename it: “ubuntu.iso” this will be easier to type later on 🙂

You should see this

ubuntu download

 

Then open spotlight (CMD + SPACE) and look for disk utility

Screen Shot 2014-10-28 at 3.03.24 PMSelect the USB volume and click on partition tab, select 1 partition, name (your choice) format choose Mac OS Extended (journaled)

Click options choose GUID then click OK and Apply

Screen Shot 2014-10-28 at 3.05.20 PM

 

Then open spotlight (CMD + SPACE) and look for command line

Let’s convert your downloaded file from .iso to .dmg, paste this in your command and press enter

hdiutil convert -format UDRW -o ~/Downloads/ubuntu.img ~/Downloads/ubuntu.iso

Then in your folder you should see two files

Screen Shot 2014-10-28 at 2.58.12 PM

don’t worry your file will be ubuntu.img.dmg

unplug your USB

run now

diskutil list

and then plug it back in and run again

diskutil list

check for the new disk(number)

Screen Shot 2014-10-28 at 3.13.29 PMfor ex mine in disk10

then run

diskutil unmountDisk /dev/disk(number)

and you get a success message

Screen Shot 2014-10-28 at 3.20.28 PM

then run

sudo dd if=~/Downloads/ubuntu.img.dmg of=/dev/disk(number) bs=1m

wait and don’t do anything

you should see this

Screen Shot 2014-10-28 at 3.24.52 PM

Screen Shot 2014-10-28 at 3.24.59 PM

don’t respond to that prompt and go back to the prompt, run

diskutil eject /dev/disk2

once you get feedback

Screen Shot 2014-10-28 at 3.26.35 PM

click ignore on the prompt

you can now remove the drive and insert it on the computer you desire to install ubuntu

When rebooting the computer hold the OPTION or ALT key down to get a choice of volume to boot from and obviously choose the USB drive and voila 🙂

In case the option key doesn’t work for you they are couple alternative to that: you can try holding the C key down or CMD + R